Tag Archives: modules

Error Loading Kernel Modules – aka “check your config files!!!1!1!!ONE”

This one’s a simple post to remind all of you out there to always¬†check your
config/settings files and be sure you don’t add junk to them.

So, to my (solved) problem.

I started noticing one day, after a few kernel updates, that my laptop wasn’t
detecting acpi events anymore (battery, leds on keyboard, screen luminosity). I
immediatly blamed it on the kernel as I’ve already had similar problems like this in the past with my old Acer 5930g.

So I said to myself: “ok, let’s just wait for an update”.
Many updates passed and still I was having the same issues until tonight.
Bored, I decided to investigate the problem and get down to the bottom of it.

I started off with checking out all errors in the logs when I came across

Feb 2 22:32:09 localhost systemd-modules-load[159]: Failed to

insert ‘vboxguest’: No such device
Feb 2 22:32:09 localhost systemd-modules-load[159]: Failed to insert
‘vboxsf’: No such device
Feb 2 22:32:11 localhost [ 2.313395] systemd[1]: Failed to start Load Kernel
Modules.

Hmm, strange. I didn’t remember adding those there. A check on the file “/etc/modules-load.d/virtualbox.conf” showed that they were actually there, so I just simply removed them from the file leaving only the “vboxdrv” module to be loaded.

I rebooted, et voilà: problem solved!

So yeah, failing to load 1 kernel module make all others fail too.

Now my

systemctl status systemd-modules-load.service

ouputs:

systemd-modules-load.service – Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service;
static)
Active: active (exited) since Sat 2013-02-02 23:10:21 CET; 3min 35s
ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 173 ExecStart=/usr/lib/systemd/systemd-modules-load
(code=exited, status=0/SUCCESS)

Hell yeah! \o/

Remember, DON’T ADD JUNK TO YOUR CONFIG FILES!!

Tagged , , , , ,